Visual Studio and .NET Framework version

By default NQuotes requires .NET Framework 4.6 or 4.5, but version 4.0 is also supported. After installation there are 2 sets of binaries installed:

Find them in folder "%TERMINAL_DATA_PATH%\MQL4\Libraries\nquotes\platforms".

Working binaries are installed in "%TERMINAL_DATA_PATH%\MQL4\Libraries\nquotes".

To switch to .NET 4.0

Visual Studio 2010 doesn't support .NET 4.5, and you'll need .NET 4.0 binaries. To switch to .NET 4.0 copy all files from "Libraries\nquotes\platforms\net40" and paste to "Libraries\nquotes" replacing existing files.

To switch to .NET 4.6 or 4.5

Sometimes you might have a .NET 4.0 version of the libraries installed. To switch to .NET 4.5 copy all files from "Libraries\nquotes\platforms\net45" and paste to "Libraries\nquotes" replacing existing files.